<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<link rel="profile" href="https://gmpg.org/xfn/11">
<meta name="viewport" content="width=device-width, initial-scale=1">

<title>How to Give Root Privileges to a User in Linux</title>
<meta name="description" content="Here learn how to grant a normal user with root privileges in Linux. We will see a few methods like add user to root group etc." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://linuxopsys.com/topics/give-normal-user-root-privileges" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Give Root Privileges to a User in Linux" />
<meta property="og:description" content="Here learn how to grant a normal user with root privileges in Linux. We will see a few methods like add user to root group etc." />
<meta property="og:url" content="https://linuxopsys.com/topics/give-normal-user-root-privileges" />
<meta property="og:site_name" content="LinuxOPsys" />
<meta property="og:image" content="https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png" />
<meta property="og:image:secure_url" content="https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="300" />
<meta property="og:image:alt" content="How to Give Root Privileges to a User in Linux" />
<meta property="og:image:type" content="image/png" />
<meta property="article:published_time" content="2022-06-16T01:59:36+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How to Give Root Privileges to a User in Linux" />
<meta name="twitter:description" content="Here learn how to grant a normal user with root privileges in Linux. We will see a few methods like add user to root group etc." />
<meta name="twitter:image" content="https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://linuxopsys.com/#organization","name":"Linuxopsys","logo":{"@type":"ImageObject","@id":"https://linuxopsys.com/#logo","url":"https://linuxopsys.com/wp-content/uploads/2021/12/Linuxopsys-logo-01.png","caption":"Linuxopsys","inLanguage":"en-US","width":"210","height":"38"}},{"@type":"WebSite","@id":"https://linuxopsys.com/#website","url":"https://linuxopsys.com","name":"Linuxopsys","publisher":{"@id":"https://linuxopsys.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png","url":"https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png","width":"700","height":"300","inLanguage":"en-US"},{"@type":"Person","@id":"https://linuxopsys.com/topics/give-normal-user-root-privileges#author","name":"Bobbin Zachariah","image":{"@type":"ImageObject","@id":"https://linuxopsys.com/wp-content/uploads/2022/06/bobbin-96x96.jpg","url":"https://linuxopsys.com/wp-content/uploads/2022/06/bobbin-96x96.jpg","caption":"Bobbin Zachariah","inLanguage":"en-US"},"worksFor":{"@id":"https://linuxopsys.com/#organization"}},{"@type":"WebPage","@id":"https://linuxopsys.com/topics/give-normal-user-root-privileges#webpage","url":"https://linuxopsys.com/topics/give-normal-user-root-privileges","name":"How to Give Root Privileges to a User in Linux","datePublished":"2022-06-16T01:59:36+00:00","dateModified":"2022-06-16T01:59:36+00:00","author":{"@id":"https://linuxopsys.com/topics/give-normal-user-root-privileges#author"},"isPartOf":{"@id":"https://linuxopsys.com/#website"},"primaryImageOfPage":{"@id":"https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png"},"inLanguage":"en-US"},{"@type":"BlogPosting","headline":"How to Give Root Privileges to a User in Linux","datePublished":"2022-06-16T01:59:36+00:00","dateModified":"2022-06-16T01:59:36+00:00","author":{"@id":"https://linuxopsys.com/topics/give-normal-user-root-privileges#author"},"publisher":{"@id":"https://linuxopsys.com/#organization"},"description":"Here learn how to grant a normal user with root privileges in Linux. We will see a few methods like add user to root group etc.","name":"How to Give Root Privileges to a User in Linux","@id":"https://linuxopsys.com/topics/give-normal-user-root-privileges#richSnippet","isPartOf":{"@id":"https://linuxopsys.com/topics/give-normal-user-root-privileges#webpage"},"image":{"@id":"https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://linuxopsys.com/topics/give-normal-user-root-privileges#webpage"}}]}</script>

<link rel='dns-prefetch' href='//static.addtoany.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://linuxopsys.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' media='all' />
<link rel='stylesheet' id='wpforms-gutenberg-form-selector-css' href='https://linuxopsys.com/wp-content/plugins/wpforms-lite/assets/css/wpforms-full.min.css?ver=1.7.4.2' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css' href='https://linuxopsys.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.6.0' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='ivory-search-styles-css' href='https://linuxopsys.com/wp-content/plugins/add-search-to-menu/public/css/ivory-search.min.css?ver=5.4.6' media='all' />
<link rel='stylesheet' id='ez-icomoon-css' href='https://linuxopsys.com/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=2.0.24' media='all' />
<link rel='stylesheet' id='ez-toc-css' href='https://linuxopsys.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=2.0.24' media='all' />
<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='bootstrap-css-css' href='https://cdnjs.cloudflare.com/ajax/libs/bootstrap/5.1.3/css/bootstrap.min.css?ver=5.9.3' media='all' />
<link rel='stylesheet' id='generate-comments-css' href='https://linuxopsys.com/wp-content/themes/generatepress/assets/css/components/comments.min.css?ver=3.1.3' media='all' />
<link rel='stylesheet' id='generate-widget-areas-css' href='https://linuxopsys.com/wp-content/themes/generatepress/assets/css/components/widget-areas.min.css?ver=3.1.3' media='all' />
<link rel='stylesheet' id='generate-style-css' href='https://linuxopsys.com/wp-content/themes/generatepress/assets/css/main.min.css?ver=3.1.3' media='all' />
<style id='generate-style-inline-css'>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</style>
<link rel='stylesheet' id='generate-child-css' href='https://linuxopsys.com/wp-content/themes/generatepress-child/style.css?ver=1655137763' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://linuxopsys.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.16' media='all' />
<style id='addtoany-inline-css'>
.addtoany_list span{
	border-radius: 15px !important;
    border: 1px solid #212d45;
}
.addtoany_list svg path:hover{
	fill: #212d45 !important;
}
.addtoany_list svg:hove path{
	fill: #212d45 !important;
}
body.single-topics #left-sidebar .addtoany_list a, body.single-topics #left-sidebar .widget .addtoany_list a{	
	display: block;   
    margin-left: 25px;
	margin-bottom:10px;
}
.nm-sidbar-table {
  position: sticky;
  background: transparent;
  width: 360px;
  margin-top: 260px;
	margin-left: 60px;
	transition: 0.5s;
}

body.single-topics .nm-sidbar-table{
	 width: 220px;
}

.newClass .nm-sidbar-table {
  --position: sticky;
  background: transparent;
  width: 360px;
  transform: translateY(80%);
  margin-left: 60px;
  align-items: flex-start;
  flex-direction: column;
  float: left;
  justify-content: flex-end;
  overflow: visible;
  padding: 0;
  position: sticky;
  top: 1rem;
  z-index: 1;
	transform: translateY(0);
transition: 0.5s;
}
body.single-topics #left-sidebar .addtoany_list span{border: 1px solid #9e9e9e;}
body.single-topics .nm-topic-single-container article .cptshare,body.single-topics .nm-topic-single-container article .addtoany_shortcode{display:none}
body.single-topics #left-sidebar .widget_a2a_share_save_widget{margin-top: 0px;}
.nm-sidbar-table {
	bottom: 0;
}
body .nm-sidbar-table .sidebar .widget {
	background-color: transparent;
}
.nm-topic-related a.nm-topic-related-post-link {
    font-size: 18px;
    min-height: 59px;
}

@media (max-width:1199px)
{
	.nm-sidbar-table {
  background: transparent;
  margin-left: 0;
}
	.sidebar .widget {
	background-color: transparent;
}
}
</style>
<style id='rocket-lazyload-inline-css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://linuxopsys.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}.wp-embed-responsive .wp-has-aspect-ratio .rll-youtube-player{position:absolute;padding-bottom:0;width:100%;height:100%;top:0;bottom:0;left:0;right:0}
</style>
<script src='https://linuxopsys.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://linuxopsys.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script id='addtoany-core-js-before'>
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color="#ffffff,#9e9e9e";
</script>
<script type="rocketlazyloadscript" async src='https://static.addtoany.com/menu/page.js' id='addtoany-core-js'></script>
<script async src='https://linuxopsys.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-jquery-js'></script>
<link rel="https://api.w.org/" href="https://linuxopsys.com/wp-json/" /><link rel="alternate" type="application/json" href="https://linuxopsys.com/wp-json/wp/v2/topics/3021" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxopsys.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxopsys.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://linuxopsys.com/?p=3021' />
<link rel="alternate" type="application/json+oembed" href="https://linuxopsys.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxopsys.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&#038;format=xml" />

<script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=G-5XQNEGJHVW"></script>
<script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-5XQNEGJHVW');
</script><style id="uagb-style-conditional-extension">@media (min-width: 1025px){body .uag-hide-desktop.uagb-google-map__wrap,body .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){body .uag-hide-tab.uagb-google-map__wrap,body .uag-hide-tab{display:none}}@media (max-width: 767px){body .uag-hide-mob.uagb-google-map__wrap,body .uag-hide-mob{display:none}}</style> <style id="wp-custom-css">
			/*::-webkit-scrollbar {
width: 12px;
}

::-webkit-scrollbar-thumb {
    width: 50% !important;
    border-radius:5px;
}
::-webkit-scrollbar {
    width: 1em;
}*/
.wp-block-preformatted {
   overflow-x: auto;
   white-space: nowrap;
}
div#ez-toc-container ul li a::before{
	top: -2px !important;
}
/*#ez-toc-container ul li ul li a {
    padding-left: 40px;
}
#ez-toc-container ul li ul li ul li a {
    padding-left: 50px;
}*/
.wp-block-code code11212{
	white-space: unset;
}
.codeblock code{
	display: block;
  white-space: pre-wrap;
  overflow-wrap: break-word;
}

#ez-toc-container ul li a {
    color: #3498D9;
    position: relative;
    /*padding-left: 25px;*/
}
/*div#ez-toc-container ul li a::before {
    color: #999;
    content: "→";
    margin-right: 1em;
    position: absolute;
    left: 0;
    top: -4px;
}*/
.single #reply-title{display:none;}
input[type="submit"]
{background: #D9645A;color:#ffffff;}
.custom-comment-cpt{margin-bottom:30px;}
input[type="text"], input[type="email"], input[type="url"]{ width:100%; }
.comment-form-cookies-consent input{margin-bottom:25px;}
.comment-heading {
    margin-top: 50px;
}
.singlemeta {
    margin-top: 20px;
}
.singlemeta span{color: #7a7a7a;
    font-size:15px}
 
/* Apin Css Change - Start */
/* Scrollbar */
/*::-webkit-scrollbar {
    width: 12px;
}
::-webkit-scrollbar-track {
	background: #999; 
}
::-webkit-scrollbar-thumb {
	background: #555; 
}*/
.lwptoc_itemWrap{
	max-height: 20rem;
	overflow-y: auto;
}
.lwptoc_itemWrap::-webkit-scrollbar{
    height:.5rem!important;
    width:.5rem!important
}
.lwptoc_itemWrap::-webkit-scrollbar-track{
    --tw-bg-opacity:1!important;
    background-color:rgb(209 213 219/var(--tw-bg-opacity))!important
}
.lwptoc_itemWrap::-webkit-scrollbar-thumb{
    --tw-bg-opacity:1!important;
    background-color:rgb(156 163 175/var(--tw-bg-opacity))!important
}
.lwptoc_itemWrap::-webkit-scrollbar-thumb{
    border-radius:.25rem!important
}
/* Apin Css Change - End */
.inside-article a{color: #3498D9}		</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="topics-template-default single single-topics postid-3021 wp-custom-logo wp-embed-responsive generatepress right-sidebar nav-float-right separate-containers header-aligned-center dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a> <header class="site-header has-inline-mobile-toggle" id="masthead" aria-label="Site" itemtype="https://schema.org/WPHeader" itemscope>
<div class="inside-header grid-container">
<div class="site-branding-container"><div class="site-logo">
<a href="https://linuxopsys.com/" title="LinuxOPsys" rel="home">
<img class="header-image is-logo-image" alt="LinuxOPsys" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20210%2038'%3E%3C/svg%3E" title="LinuxOPsys" data-lazy-srcset="https://linuxopsys.com/wp-content/uploads/2021/12/website-logo.png.webp 1x,  https://linuxopsys.com/wp-content/uploads/2021/12/website-logo.png.webp 2x" width="210" height="38" data-lazy-src="https://linuxopsys.com/wp-content/uploads/2021/12/website-logo.png.webp" /><noscript><img  class="header-image is-logo-image" alt="LinuxOPsys" src="https://linuxopsys.com/wp-content/uploads/2021/12/website-logo.png.webp" title="LinuxOPsys" srcset="https://linuxopsys.com/wp-content/uploads/2021/12/website-logo.png.webp 1x,  https://linuxopsys.com/wp-content/uploads/2021/12/website-logo.png.webp 2x" width="210" height="38" /></noscript>
</a>
</div><div class="site-branding">
</div></div> <nav class="main-navigation mobile-menu-control-wrapper" id="mobile-menu-control-wrapper" aria-label="Mobile Toggle">
<button data-nav="site-navigation" class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="screen-reader-text">Menu</span> </button>
</nav>
<nav class="main-navigation sub-menu-right" id="site-navigation" aria-label="Primary" itemtype="https://schema.org/SiteNavigationElement" itemscope>
<div class="inside-navigation grid-container">
<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">Menu</span> </button>
<div id="primary-menu" class="main-nav"><ul id="menu-main-menu" class="menu sf-menu"><li id="menu-item-1023" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1023"><a href="https://linuxopsys.com/">HOME</a></li>
<li id="menu-item-150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-150"><a href="#">LINUX<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153"><a href="https://linuxopsys.com/guide-on-linux-commands">Commands</a></li>
<li id="menu-item-2880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2880"><a href="https://linuxopsys.com/installation-guides">Installation</a></li>
</ul>
</li>
<li id="menu-item-1205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1205"><a href="https://linuxopsys.com/subscribe-newsletter">NEWSLETTER</a></li>
<li class="astm-search-menu is-menu popup menu-item"><a href="#" aria-label="Search Icon Link"><svg width="20" height="20" class="search-icon" role="img" viewBox="2 9 20 5" focusable="false" aria-label="Search">
<path class="search-icon-path" d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path></svg></a></li></ul></div> </div>
</nav>
</div>
</header>
<div class="site grid-container container hfeed" id="page">
<div class="site-content" id="content">
<script type="rocketlazyloadscript">
jQuery(window).scroll(function(){
    if (jQuery(this).scrollTop() > 370) {
       jQuery('body').addClass('newClass');
    } else {
       jQuery('body').removeClass('newClass');
    }
});
</script>
<div class="content-area" id="primary">
<div class="container nm-topic-single-main-container">
<div class="row no-gutter">
<div class="col-md-3 col-sm-12 col-xs-12 nm-sidebar-left-right">
<div class="nm-sidbar-table">
<div class="widget-area sidebar is-left-sidebar" id="left-sidebar">
<div class="inside-left-sidebar">
<aside id="block-27" class="widget inner-padding widget_block"></aside><aside id="block-28" class="widget inner-padding widget_block"><p><div class="url_block">
<p><a href="https://linuxopsys.com/topics/modern-alternatives-to-linux-commands">13 Modern Alternatives to Linux Commands</a></p>


<p><a href="https://linuxopsys.com/topics/dotfiles-in-linux-explained" target="_blank" rel="noreferrer noopener">Dotfiles in Linux Explained</a></p>


<p><a href="https://linuxopsys.com/topics/basic-linux-commands">Basic Linux Commands You Should Know</a></p>
</div></p>
</aside> </div>
</div>
</div>
</div>
<div class="col-md-6 col-sm-12 col-xs-12">

<main class="nm-topic-single-container">
<article id="post-3021" class="post-3021 topics type-topics status-publish has-post-thumbnail hentry" itemtype="https://schema.org/CreativeWork" itemscope>
<div class="inside-article">
<header class="entry-header" aria-label="Content">
<h1 class="entry-title" itemprop="headline">How to Give Root Privileges to a User in Linux</h1><div class='singlemeta' style='display: inline-block;'><span>Last updated: June 16, 2022</span></div> </header>
<div class="featured-image page-header-image-single grid-container grid-parent">
<img width="700" height="300" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20700%20300'%3E%3C/svg%3E" class="attachment-full size-full wp-post-image" alt="" itemprop="image" data-lazy-srcset="https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png.webp 700w,  https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image-300x129.png.webp 300w" data-lazy-sizes="(max-width: 700px) 100vw, 700px" data-lazy-src="https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png.webp" /><noscript><img width="700" height="300" src="https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png.webp" class="attachment-full size-full wp-post-image" alt="" itemprop="image" srcset="https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image.png.webp 700w,  https://linuxopsys.com/wp-content/uploads/2022/06/linux-give-user-root-permissions-featured-image-300x129.png.webp 300w" sizes="(max-width: 700px) 100vw, 700px" /></noscript> </div>
<div class="entry-content" itemprop="text">
<p>The “root” super user is the king of users in Linux/Unix. Having root access grants full and unlimited access to the Linux box.</p>
<p>The root or super user has full permission to read(r), write (w) and execute(x)&nbsp; any file. By default root user id is '0'.</p>
<p>In this tutorial, I will show you how to allow root access to a user in a Linux system. Typically, root level access is used in system administration. So it is always a pain to give root access to other users. You need to be careful and should withdraw the access once the need to do so is over.</p>
<p><mark style="background-color:var(--global-color-8)" class="has-inline-color">Remember: It's safer to perform superuser tasks using sudo command than log in as a root account.</mark></p>
<p>I am going to create two users namely user1 and user2. Then I will show you how to give root access to 'user1'.</p>
<div id="ez-toc-container" class="ez-toc-v2_0_24 counter-hierarchy counter-decimal ez-toc-grey">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Method_1_Adding_to_Root_Group_using_usermod" title="Method&nbsp; 1: Adding to Root Group using usermod">Method&nbsp; 1: Adding to Root Group using usermod</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Method_2_Adding_to_Root_Group_using_Useradd_Command" title="Method 2:&nbsp;Adding to Root Group using Useradd Command">Method 2:&nbsp;Adding to Root Group using Useradd Command</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Method_3_Editing_etcpasswd_file" title="Method 3: Editing /etc/passwd file">Method 3: Editing /etc/passwd file</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Method_4_Setting_as_Sudo_User" title="Method 4: Setting as Sudo User">Method 4: Setting as Sudo User</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Conclusion" title="Conclusion">Conclusion</a></li></ul></nav></div>
<h2><span class="ez-toc-section" id="Method_1_Adding_to_Root_Group_using_usermod"></span>Method&nbsp; 1: Adding to Root Group using usermod<span class="ez-toc-section-end"></span></h2>
<p>Let's see how we can grant normal user root access by adding to root group.</p>
<pre class="wp-block-preformatted codeblock"><code>adduser user1
adduser user2
groupadd test</code></pre>
<p>These are the groups I have in my Linux box.</p>
<pre class="wp-block-preformatted codeblock"><code>groups
root bin daemon sys adm disk wheel</code></pre>
<p>I am going to add user1 to root group as follows:</p>
<pre class="wp-block-preformatted"><code>usermod -G root user1</code></pre>
<p>The following <a href="https://linuxopsys.com/topics/usermod-command-in-linux" target="_blank" rel="noreferrer noopener">usermod</a> command given below provides the existing user with the root privilege</p>
<pre class="wp-block-preformatted"><code>usermod -g 0 -o root_user</code></pre>
<h2><span class="ez-toc-section" id="Method_2_Adding_to_Root_Group_using_Useradd_Command"></span>Method 2:&nbsp;Adding to Root Group using Useradd Command<span class="ez-toc-section-end"></span></h2>
<p>I have added a new user, 'user3' to the root group using one single command:</p>
<pre class="wp-block-preformatted codeblock"><code>useradd -m -G root user3
groups user3
user3 : user3 root</code></pre>
<p>Another option using <a href="https://linuxopsys.com/topics/useradd-command-in-linux" target="_blank" rel="noreferrer noopener">useradd</a> command</p>
<pre class="wp-block-preformatted"><code>useradd -c “Imitation Root” -d /home/root_user -m -k /etc/skel -s /bin/bash -u 0 -o -g root root_user</code></pre>
<h2><span class="ez-toc-section" id="Method_3_Editing_etcpasswd_file"></span>Method 3: Editing /etc/passwd file<span class="ez-toc-section-end"></span></h2>
<p>Edit /etc/passwd for the particular user. Change the user's UID and GID to '0'. This will&nbsp;give root permissions&nbsp;to user.</p>
<pre class="wp-block-preformatted codeblock"><code>root:x:0:0:root:/root:/bin/bash
temproot:x:128:128:temproot</code></pre>
<p>Now, temproot user should have root privilege:</p>
<pre class="wp-block-preformatted codeblock"><code>root:x:0:0:root:/root:/bin/bash
temproot:x:0:0:temproot</code></pre>
<p>Note: This is not the&nbsp;recommended method for granting root access</p>
<h2><span class="ez-toc-section" id="Method_4_Setting_as_Sudo_User"></span>Method 4: Setting as Sudo User<span class="ez-toc-section-end"></span></h2>
<p>The sudo configuration file is <a href="https://linuxopsys.com/topics/add-user-to-sudoers-file-on-ubuntu" target="_blank" rel="noreferrer noopener">/etc/sudoers</a> and you can edit this file using visudo command: # visudo.</p>
<p>Using visudo protects from conflicts and guarantees that the right syntax is used.</p>
<p>To give full access (grant root privileges) to specific users</p>
<p>Add the entry given below in the file:</p>
<pre class="wp-block-preformatted"><code>bob, tom ALL=(ALL) ALL</code></pre>
<p>Following this method is not a good idea because this allows both bob and tom to use the su command to grant themselves permanent root privileges. Thereby skipping the command logging features of sudo.</p>
<p>Granting access to specific files&nbsp;to one&nbsp;particular user</p>
<p>This entry allows bob and all the other&nbsp;members of the group operator to gain access to all the program files in the /sbin and /usr/sbin directories,&nbsp;as well as&nbsp;the privilege of running the command /usr/oracle/backup.pl.</p>
<pre class="wp-block-preformatted"><code>bob, %operator ALL= /sbin/, /usr/sbin, /usr/oracle/backup.pl</code></pre>
<h2><span class="ez-toc-section" id="Conclusion"></span>Conclusion<span class="ez-toc-section-end"></span></h2>
<p>In this tutorial, we learned how to allow root access to a user in a Linux system. </p>
<p>Login in as root and running commands is dangerous because all commands are with the highest privileges. Accident mistakes can even delete root directories and unsafe to run programs with a root shell.</p>
<div class="row vk-social-share">
<div class="col-xl-6 col-12">
<div class="share-icon">
<div class="addtoany_shortcode"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://linuxopsys.com/topics/give-normal-user-root-privileges" data-a2a-title="How to Give Root Privileges to a User in Linux"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="LinkedIn" rel="nofollow noopener" target="_blank"></a></div></div>
</div>
</div>
<div class="col-xl-6 col-12">
<div class="vote-wrapper">
<input type="hidden" id="wp_ajax_url" name="wp_ajax_url" value="https://linuxopsys.com/wp-admin/admin-ajax.php">
<span>Did you find this article helpful?</span>
<div class="vote-container">
<div class="pld-like-dislike-wrap pld-custom">
<div class="pld-like-wrap  pld-common-wrap">
<a id="topic_post_like" href="javascript:void(0)" class="pld-like-trigger pld-like-dislike-trigger" title="Like" data-post-id="3021" data-trigger-type="like" data-restriction="cookie" data-already-liked="">
<img width="512" height="512" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20512%20512'%3E%3C/svg%3E" alt="Like" data-lazy-src="https://linuxopsys.com/wp-content/uploads/2022/06/smile-like.png.webp"><noscript><img width="512" height="512" src="https://linuxopsys.com/wp-content/uploads/2022/06/smile-like.png.webp" alt="Like"></noscript>
</a>
</div>
<div class="pld-dislike-wrap  pld-common-wrap">
<a id="topic_post_dislike" href="javascript:void(0)" class="pld-dislike-trigger pld-like-dislike-trigger" title="Dislike" data-post-id="3021" data-trigger-type="dislike" data-restriction="cookie" data-already-liked="">
<img width="512" height="512" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20512%20512'%3E%3C/svg%3E" alt="" data-lazy-src="https://linuxopsys.com/wp-content/uploads/2022/06/sad-dislike.png.webp"><noscript><img width="512" height="512" src="https://linuxopsys.com/wp-content/uploads/2022/06/sad-dislike.png.webp" alt=""></noscript>
</a>
</div>
</div>
</div>
</div>
</div>
<div class="col-12 liked_topic">
<span>We are glad you liked the article. Share with your friends.</span>
<div class="addtoany_shortcode"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://linuxopsys.com/topics/give-normal-user-root-privileges" data-a2a-title="How to Give Root Privileges to a User in Linux"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="LinkedIn" rel="nofollow noopener" target="_blank"></a></div></div>
</div>
<div class="col-12 disliked_topic">
<form action="" class="disliked-form" method="post" accept-charset="UTF-8">
<div>
<div class="disliked-massage">
<p>Sorry about that.</p>
<label class="social-area__label">How can we improve it?</label>
</div>
<div class="rate-share-form">
<div class="col-12">
<div class="form">
<textarea required="required" placeholder="Enter your message..." name="dislike_feedback" cols="60" rows="5"></textarea>
</div>
</div>
</div>
<div class="form-actions">
<div>
<div class="d-flex justify-content-end">
<input class="webform-submit button-primary btn btn-submit-feedback btn--medium btn--block-sp form-submit ajax-processed" type="submit" id="edit-submit" name="sub_feedback" value="Submit Feedback">
</div>
</div>
</div>
</div>
</form>
</div>
</div>

<div class="vk_about-author">
<h2>About The Author</h2>
<div class="row">
<div class="col-12 col-xl-3">
<div class="image">
<h3>Bobbin Zachariah</h3>
<img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Bobbin Zachariah" data-lazy-src="https://linuxopsys.com/wp-content/uploads/2022/06/bobbin-150x150.jpg.webp" /><noscript><img width="150" height="150" src="https://linuxopsys.com/wp-content/uploads/2022/06/bobbin-150x150.jpg.webp" class="attachment-thumbnail size-thumbnail" alt="Bobbin Zachariah" /></noscript> 
</div>
</div>
<div class="col-12 col-xl-9">
<p>
Bobbin started his career in IT in the year 2000 as a computer science instructor and worked as a Linux system engineer and senior analyst roles. Currently working in DevOps environments to increase efficiency and improve delivery time in AWS Cloud infrastructure. He is certified in RHEL, CCNA, and MCP and holds a Masters's in computer science. When in his free time love playing cricket, blogging, and listening to music. </p>
</div>
</div>
</div>

</div>
<div class="cptshare"><style>
    .nm-widget-title svg{
        fill: #D9645A;
    }
    </style><div class="nm-widget-title wp-block-uagb-icon-list uagb-icon-list__outer-wrap uagb-icon-list__layout-vertical uagb-block-1b1009b2">
<div class="uagb-icon-list__wrap">
<div class="wp-block-uagb-icon-list-child uagb-icon-list-repeater uagb-icon-list__wrapper uagb-block-d19f6de2 nm-title">
<div class="uagb-icon-list__content-wrap"><span class="uagb-icon-list__source-wrap"><span class="uagb-icon-list__source-icon">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path d="M496.25 202.52l-110-15.44 41.82-104.34c6.67-16.64-11.6-32.18-26.59-22.63L307.44 120 273.35 12.82C270.64 4.27 263.32 0 256 0c-7.32 0-14.64 4.27-17.35 12.82l-34.09 107.19-94.04-59.89c-14.99-9.55-33.25 5.99-26.59 22.63l41.82 104.34-110 15.43c-17.54 2.46-21.68 26.27-6.03 34.67l98.16 52.66-74.48 83.54c-10.92 12.25-1.72 30.93 13.29 30.93 1.31 0 2.67-.14 4.07-.45l108.57-23.65-4.11 112.55c-.43 11.65 8.87 19.22 18.41 19.22 5.15 0 10.39-2.21 14.2-7.18l68.18-88.9 68.18 88.9c3.81 4.97 9.04 7.18 14.2 7.18 9.54 0 18.84-7.57 18.41-19.22l-4.11-112.55 108.57 23.65c17.36 3.76 29.21-17.2 17.35-30.49l-74.48-83.54 98.16-52.66c15.64-8.39 11.5-32.2-6.04-34.66zM338.51 311.68l-51.89-11.3 1.97 53.79L256 311.68l-32.59 42.49 1.96-53.79-51.89 11.3 35.6-39.93-46.92-25.17 52.57-7.38-19.99-49.87 44.95 28.62L256 166.72l16.29 51.23 44.95-28.62-19.99 49.87 52.57 7.38-46.92 25.17 35.61 39.93z"></path></svg></span></span>
<div class="uagb-icon-list__label-wrap"><span class="uagb-icon-list__label">
SHARE</span>
</div>
</div>
</div>
</div>
</div></div><div class="addtoany_shortcode"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://linuxopsys.com/topics/give-normal-user-root-privileges" data-a2a-title="How to Give Root Privileges to a User in Linux"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Flinuxopsys.com%2Ftopics%2Fgive-normal-user-root-privileges&amp;linkname=How%20to%20Give%20Root%20Privileges%20to%20a%20User%20in%20Linux" title="LinkedIn" rel="nofollow noopener" target="_blank"></a></div></div><div class="comment-heading"><h2>Comments</h2></div>
<div class="comments-area">
<div class="custom-comment-cpt">Please add comments below to provide the author your ideas, appreciation and feedback.</div>
<h3 class="comment-reply-title">
<a href="https://linuxopsys.com/topics/give-normal-user-root-privileges#respond">Leave a Reply</a></h3>
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/topics/give-normal-user-root-privileges#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://linuxopsys.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" required></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" required />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" required />
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" />
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3021' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="wantispam-required-fields"><input type="hidden" name="wantispam_t" class="wantispam-control wantispam-control-t" value="1655387953" /><div class="wantispam-group wantispam-group-q" style="clear: both;">
<label>Current <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="126b775260">[email&#160;protected]</a> <span class="required">*</span></label>
<input type="hidden" name="wantispam_a" class="wantispam-control wantispam-control-a" value="2022" />
<input type="text" name="wantispam_q" class="wantispam-control wantispam-control-q" value="7.3.0" autocomplete="off" />
</div>
<div class="wantispam-group wantispam-group-e" style="display: none;">
<label>Leave this field empty</label>
<input type="text" name="wantispam_e_email_url_website" class="wantispam-control wantispam-control-e" value="" autocomplete="off" />
</div>
</div></form> </div>
</div>
</div>

<ul class="nm-tags-topics-single">
</ul>
</div>
</article>
</main>
</div>
<div class="col-md-3 col-sm-12 col-xs-12">
<div class="widget-area sidebar is-right-sidebar" id="right-sidebar">
<div class="inside-right-sidebar">
<aside id="block-24" class="widget inner-padding widget_block"><p><style>
    .nm-widget-title svg{
        fill: #D9645A;
    }
    </style><div class="nm-widget-title wp-block-uagb-icon-list uagb-icon-list__outer-wrap uagb-icon-list__layout-vertical uagb-block-1b1009b2">
<div class="uagb-icon-list__wrap">
<div class="wp-block-uagb-icon-list-child uagb-icon-list-repeater uagb-icon-list__wrapper uagb-block-d19f6de2 nm-title">
<div class="uagb-icon-list__content-wrap"><span class="uagb-icon-list__source-wrap"><span class="uagb-icon-list__source-icon">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path d="M496.25 202.52l-110-15.44 41.82-104.34c6.67-16.64-11.6-32.18-26.59-22.63L307.44 120 273.35 12.82C270.64 4.27 263.32 0 256 0c-7.32 0-14.64 4.27-17.35 12.82l-34.09 107.19-94.04-59.89c-14.99-9.55-33.25 5.99-26.59 22.63l41.82 104.34-110 15.43c-17.54 2.46-21.68 26.27-6.03 34.67l98.16 52.66-74.48 83.54c-10.92 12.25-1.72 30.93 13.29 30.93 1.31 0 2.67-.14 4.07-.45l108.57-23.65-4.11 112.55c-.43 11.65 8.87 19.22 18.41 19.22 5.15 0 10.39-2.21 14.2-7.18l68.18-88.9 68.18 88.9c3.81 4.97 9.04 7.18 14.2 7.18 9.54 0 18.84-7.57 18.41-19.22l-4.11-112.55 108.57 23.65c17.36 3.76 29.21-17.2 17.35-30.49l-74.48-83.54 98.16-52.66c15.64-8.39 11.5-32.2-6.04-34.66zM338.51 311.68l-51.89-11.3 1.97 53.79L256 311.68l-32.59 42.49 1.96-53.79-51.89 11.3 35.6-39.93-46.92-25.17 52.57-7.38-19.99-49.87 44.95 28.62L256 166.72l16.29 51.23 44.95-28.62-19.99 49.87 52.57 7.38-46.92 25.17 35.61 39.93z"></path></svg></span></span>
<div class="uagb-icon-list__label-wrap"><span class="uagb-icon-list__label">
Best Articles</span>
</div>
</div>
</div>
</div>
</div></p>
</aside><aside id="block-25" class="widget inner-padding widget_block"><p><a class="nm-topic-post-link" href="https://linuxopsys.com/topics/vi-editor-useful-commands">Vi Editor &#8211; Useful Commands</a><a class="nm-topic-post-link" href="https://linuxopsys.com/topics/find-command-linux">Find Command Linux &#8211; Examples + Options</a><a class="nm-topic-post-link" href="https://linuxopsys.com/topics/grep-command-in-linux">Grep command in Linux &#8211; Options + Examples</a><a class="nm-topic-post-link" href="https://linuxopsys.com/topics/tar-command-in-linux">Tar Command in Linux &#8211; Options + Examples</a><a class="nm-topic-post-link" href="https://linuxopsys.com/topics/add-user-to-group-in-linux">How to Add User to Group (Secondary) in Linux</a></p>
</aside> </div>
</div> </div>
</div>
</div>
</div>
</div>
</div>
<div class="site-footer footer-bar-active footer-bar-align-right">
<div id="footer-widgets" class="site footer-widgets">
<div class="footer-widgets-container grid-container">
<div class="inside-footer-widgets">
<div class="footer-widget-1">
<aside id="block-19" class="widget inner-padding widget_block">
<h4 class="alignfull nm-related-title"> Related Posts</h4>
</aside><aside id="block-18" class="widget inner-padding widget_block"><p><div class="container-fluid nm-no-pad nm-topic-related-container"> <div class="row"><div class="col-md-4 col-sm-12 col-xs-12 nm-topic-related"><span>Apr 25, 2022</span><a class="nm-topic-related-post-link" href="https://linuxopsys.com/topics/list-and-set-environment-variables-in-linux">List and Set Environment Variables in Linux</a><a href="https://linuxopsys.com/topics/list-and-set-environment-variables-in-linux" class="nm-related-img-div"><div style="background:url(https://linuxopsys.com/wp-content/uploads/2022/04/list-set-enviornment-variables-featured-image.png.webp)" class="img-responsive"></div></a></div><div class="col-md-4 col-sm-12 col-xs-12 nm-topic-related"><span>Jun 12, 2022</span><a class="nm-topic-related-post-link" href="https://linuxopsys.com/topics/cp-command-in-linux">CP Command in Linux</a><a href="https://linuxopsys.com/topics/cp-command-in-linux" class="nm-related-img-div"><div style="background:url(https://linuxopsys.com/wp-content/uploads/2022/03/cp-cmd-featured-image.png.webp)" class="img-responsive"></div></a></div><div class="col-md-4 col-sm-12 col-xs-12 nm-topic-related"><span>May 02, 2022</span><a class="nm-topic-related-post-link" href="https://linuxopsys.com/topics/passwd-command-in-linux">Passwd Command in Linux &#8211; Options + Examples</a><a href="https://linuxopsys.com/topics/passwd-command-in-linux" class="nm-related-img-div"><div style="background:url(https://linuxopsys.com/wp-content/uploads/2022/02/passwd-cmd-featured-image.png)" class="img-responsive"></div></a></div></div></div></p>
</aside> </div>
</div>
</div>
</div>
<footer class="site-info" aria-label="Site" itemtype="https://schema.org/WPFooter" itemscope>
<div class="inside-site-info grid-container">
<div class="footer-bar">
<aside id="nav_menu-3" class="widget inner-padding widget_nav_menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-93" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93"><a href="https://linuxopsys.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-175"><a href="https://linuxopsys.com/terms-of-service">Terms of Service</a></li>
<li id="menu-item-312" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-312"><a href="https://linuxopsys.com/contact">Contact</a></li>
</ul></div></aside> </div>
<div class="copyright-bar">
© 2022 LinuxOPsys </div>
</div>
</footer>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><style type="text/css" media="screen">.is-menu path.search-icon-path { fill: #f04949;}body .popup-search-close:after, body .search-close:after { border-color: #f04949;}body .popup-search-close:before, body .search-close:before { border-color: #f04949;}</style><div id="is-popup-wrapper" style="display:none"><div class="popup-search-close"></div><div class="is-popup-search-form"> <style type="text/css">
					.is-form-id-114 .is-search-submit:focus,
			.is-form-id-114 .is-search-submit:hover,
			.is-form-id-114 .is-search-submit,
            .is-form-id-114 .is-search-icon {
			color: #ffffff !important;            background-color: #f04949 !important;            border-color: #d9645a !important;			}
                        	.is-form-id-114 .is-search-submit path {
					fill: #ffffff !important;            	}
            			</style>
<form class="is-search-form is-form-style is-form-style-1 is-form-id-114" action="https://linuxopsys.com/" method="get" role="search"><label for="is-search-input-114"><span class="is-screen-reader-text">Search for:</span><input type="search" id="is-search-input-114" name="s" value="" class="is-search-input" placeholder="What are you searching for?" autocomplete=off /></label><input type="submit" value="Search" class="is-search-submit" /></form></div></div><script src='https://linuxopsys.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.6.0' id='mpp_gutenberg_tabs-js'></script>
<script src='https://linuxopsys.com/wp-content/plugins/anti-spam/assets/js/anti-spam.js?ver=7.3.0' id='anti-spam-script-js'></script>
<script type="rocketlazyloadscript" src='https://cdnjs.cloudflare.com/ajax/libs/bootstrap/5.1.3/js/bootstrap.min.js?ver=5.9.3' id='bootstrap-js-js'></script>
<script src='https://linuxopsys.com/wp-content/themes/generatepress-child/assets/custom.js?ver=5.9.3' id='custom-js-js'></script>
<!--[if lte IE 11]>
<script src='https://linuxopsys.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.3' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src='https://linuxopsys.com/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.3' id='generate-menu-js'></script>
<script src='https://linuxopsys.com/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
<script id='ivory-search-scripts-js-extra'>
var IvorySearchVars = {"is_analytics_enabled":"1"};
</script>
<script src='https://linuxopsys.com/wp-content/plugins/add-search-to-menu/public/js/ivory-search.min.js?ver=5.4.6' id='ivory-search-scripts-js'></script>
<script src='https://linuxopsys.com/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?ver=2.2.0' id='jquery-smooth-scroll-js'></script>
<script src='https://linuxopsys.com/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?ver=2.2.1' id='js-cookie-js'></script>
<script src='https://linuxopsys.com/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?ver=1.9.2' id='jquery-sticky-kit-js'></script>
<script id='ez-toc-js-js-extra'>
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"1","width":"auto","scroll_offset":"30"};
</script>
<script src='https://linuxopsys.com/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?ver=2.0.24-1655185160' id='ez-toc-js-js'></script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://linuxopsys.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script></body>
</html>
